Child pages
  • WinFrog Navigation User Guide
Skip to end of metadata
Go to start of metadata


Table of Contents


Introduction

Overview

WinFrog is an integrated navigation and data management software package. It was developed by Racal Pelagos, Inc. of San Diego, California (currently Fugro Pelagos, Inc.). IODP uses it to manage and collect data from the following sources:

  • Two onboard Trimble Global Positioning System (GPS): Position and Heading
  • Ship’s Gyro: Heading
  • Bathy 2010 System: Water Depth
  • SeaLink Magnetometer: Seafloor magnetics


In addition to data collection, WinFrog:

  • Calculates and displays navigational data
  • Provides data services to a variety of applications onboard the JR


Master and Back-up Computers

WinFrog software is installed on two mirrored PC computers in the Underway (UW) lab. Either one can be set up as the “Master”, with the other one ready as the back-up machine.

The master machine must have the hardware security key (blue dongle) connected to it, allowing the software to be run. Only one of the two PCs (WinFrog 1 & 2) can be running WinFrog on the network at a time since they share the same IP address. A machine without the key can only run in “Demo” mode, acting as the Smart Remote .

When switching between WinFrog 1 & 2 as the master, it is best to:

  1. Stop WinFrog
  2. Move the dongle and necessary COM port cables
  3. Restart WinFrog

There will be another machine running the software as a Smart Remote that will display our position for the ship-wide video distribution. This remote machine currently resides in the MCS’s server-room.

Software

The current version of WinFrog is V.3.10.19. The original software disk should be stored in the UW lab.  WinFrog operates on Windows XP. WinFrog 1 & 2 each have a 4-port RS-232 serial expansion board to connect to the external devices (GPS, gyro, bathymetry). Since version 3.7.14, WinFrog has an IODP requested modification, Position Averaging Utility, to perform site fixes. A Site Fix can be created using the “Unintelligent Design Team” SiteFix Software (LabView program.)

Vendor User Guide

Electronic versions of the WinFrog Vendor User Guide are available as reference material on the WinFrog computers and in the WinFrog Software. 

Startup and Working Directories

Overview

WinFrog uses an initiation file (WinFrogini.wfg) to save all of the current settings (e.g., what vehicles are defined, coastlines, and window configurations) and any changes in the program's default settings, including, but not limited to the:

• Placement of the open window

• Names and placement of any defined vehicles and devices

• Geodetic parameters

It also contains the version of WinFrog that created the file. The file is used to configure WinFrog every time the program is started and is created in the system directory (C:\Users). This file is created in the following folder (Windows 10): C:\Users\Public\). The file is overwritten and saved when WinFrog is exited properly.

Saving Files

Regularly save a copy of the WinFrogini.wfg file, both on the working computer and as a backup. Currently there is no set place to save the backup file; however, one of the servers would be best.

Procedures: Start Up

1. Launch WinFrog from the desktop (Figure 2.) On the Master, the program should open with no problems.

—  If a dialogue box opens up asking if you want to run in “demo” mode, then cancel and try opening WinFrog again.

—  If the program does not open after a few tries, it is usually a problem with the WinFrogini.wfg file. Replace the WinFrogini.wfg file with one of the previously saved versions.

2. Click File -> System Config File... -> Load. If there appears to be a problem with the setup of the I/O Devices, vehicle graphics or vehicle text window, upload a recently saved WinFrog configuration file.

—  Always reboot the computer after any kind of computer crash or freeze.

—  If WinFrog still does not open after trying all of this, call an MCS to trouble shoot. The worst-case scenario is that WinFrog will have to be reinstalled.

3. Save a new System Configuration file by clicking File -> System Config File… -> Save. This file can then be loaded at any time to reset the system configuration to the saved parameters.

Note: Name the file using the following naming convention: Exp#_date.cfg (e.g., 317_20100123.cfg).

Working Directories

WinFrog will write its *.dat and *.raw data output files to a directory.  Before you launch WinFrog, create and setup a new Expedition specific directory (follow the procedure in the next section.)  This folder contains the following sub-folders:

  • config: This folder contains the file WF Default Config date.cfg which holds the configuration data that WinFrog uses to define the data I/O, navigational displays and various other settings.
  • dat: An empty working directory that will hold your data files that you log. Also must contain a .ALG file in which WinFrog will keep a list of all data files created.
  • Logs: An empty working directory that will store your manual events.
  • pictures: An empty working directory that will hold screen captures that you take.
  • position: An empty working directory that will hold your position files from the Position Averaging Utility
  • raw: An empty working directory that will hold your raw dat files that you log.
  • survey lines: An empty working directory that will hold your survey data (rarely used).
  • vehicle: This folder contains the file JR Rev2.veh which holds the graphical information that defines the JR’s outline in the WinFrog graphic display window.
  • waypoints: An empty working directory that will hold waypoint data files you enter.

Procedure: Set Up Working Directories

To set up working directories, perform these steps:

  1. Find and copy the “Copy Me Expedition Folder” (IODP_Share\_IODP_Technical_Manual\Underway Geophysics\Current\Navigation and Position\)
  2. Rename the Copy Me folder “Exp nnn” Use the official designation of your current Expedition, Transit or APL. (i.e. Exp 372 or Exp 372T.)
  3.  Select File > Select Working Directories.
  4. Use the Browse button (Figure 4) to select the new directories created in the previous steps.
  5. Click OK.


Vehicle Configuration

Overview

In WinFrog, the JOIDES Resolution is a Vehicle. The vehicle configuration process allows the user to create a new vehicle or modify an existing vehicle.

Procedure: Create or Configure the Vehicle

To create a new vehicle or configure an existing vehicle, perform these steps:

  1. Select Configure -> Vehicles to open the Configure Vehicles window (Figure 5).
  2. Select the Vehicle Presentation button (red box) in the Configure Vehicles menu window to open that dialog box (Figure 6) and set the following parameters.
  • Name the vehicle
  • Set the graphic color
  • Set the trail color
  • Clear the ship’s tail memory, if required
  1. Select the Configure Vehicle Outline button (green box) in the Configure Vehicles (Figure 5) window to define the vehicle outline and size (Table 1) of the vehicle.
  • You may load the values from a previously saved “*.veh” file. 
  • When a new vehicle is entered, save the values for future use (e.g., Exp#.veh).



You may also configure vehicle tracking offsets from the Configure Vehicles window. These offsets correspond to different devices that are added to the vehicle and are entered in relation to the moon pool. When adding a new device to the vehicle you may enter its offset manually or choose it from the Configure Offsets list(Figure 7).

WinFrog Coastlines

Overview

WinFrog has the ability to display shorelines or bathymetric contours in its Graphics window by means of loading a “Picture” file. This file has a “.pic” file extension, and it is an ASCII, comma-delimited text format.

The file consists of three record types:

  • Picture Point Records to control the “pen up” and “pen down” functions.
  • Picture Control Records to control the line color and style functions.
  • Picture Text Records to control the way text is represented.

See the WinFrog Vendor User Guide for exact definitions of the individual data fields.

The data points in these files may be:

  • Entered manually
  • Read directly from an interfaced digitizer
  • Obtained by downloading and converting a file from some third party source (recommended.)

Third Party File Sources (Coastlines)

The usual source for third-party files is the National Geophysical Data Center (NGDC.) The NGDC provides world-wide digitized shorelines over the Internet free of charge. This is the recommended source for displaying coastline data in WinFrog for an IODP Expedition.

Downloading Files from the National Geophysical Data Center

The USGS Coastline Extractor was created by Rich Signell and is hosted by NOAA/National Geophysical Data Center (NGDC.) It can be downloaded as part of the GEOphysical DAta System (GEODAS) software tool.  The link is:

https://ngdc.noaa.gov/mgg/geodas/trackline.html

The Coastline Extractor is downloaded on both WinFrog Machines. The coastline data can be extracted without internet access. To download a source file, perform these steps:

  1. Open the GEODAS Coastline Extractor.                
  2. Define the Geographic Range required. Remember that when defining the area, west longitudes and south latitudes are entered as negative values. Try to define the limits accurately to keep the file size small. 
  3. Define which Coastline database to use.   The smaller the scale, the better resolution (and the larger the file size.) Depending upon proximity to shore, WCL (World Coast Line) 1:5,000,000 scale works best.
  4. Select the method of File Compression for extracted ASCII data, if any, to use in conjunction with the file transfer. The choices are:
    • None
    • GNU GZIP
    • Unix Compressed
    • ZIP
  5. The Coast Format Options offers a selection of formats recognized by common mapping software packages such as ArcInfo. For WinFrog, select the “Matlab” option.
  6. The Coast Preview Option allows the user to preview the data using the GMT Plot option before downloading to ensure the proper geographical limits were defined. The two choices are:
    • No Preview
    • GMT Plot
  7. Click on the SUBMIT - Extract the Coastline File button to proceed to the preview.  Wait for the preview to generate. If you abort and reload, it complicates the process.
  8. If the preview is not to your liking, click on the browser Back button to return to the configuration page. Reconfigure the options as required.
  9. Save the file to an appropriate location ( C:\UW Support Apps\Makepic) on the computer’s hard drive by right clicking on the *.dat link and selecting ‘Save Link As’. 
  10. The program “Makepic” described below can be configured to create a .pic file with a custom name. The downloaded ASCII file is defined by a “.dat” or “.txt” file extension. 

Making the Downloaded File WinFrog Ready

The data from the Coastline Extractor must be reformatted to WinFrog’s .PIC file format using the MakePic.m Matlab script (or Makepic.py python script.)

To convert the file, perform these steps.

  1. Double click on C:\Makepic\MAKEPIC.m to start Matlab and run the script.
  2. Edit the script by changing the filename to load (i.e. the extracted coastline (e.g. x372.dat.)
  3. Edit the output (*.pic) filename (file name and extension example: ant.pic)
  4. Run the Script (click the green Triangle button in Matlab.)


NOTE from x369 Tech Report: The MakePic.exe DOS executable will not run in the new Win10 Enterprise 64-bit environment. Makepic.exe was installed on the GC3 PC for use.

A header must be included on the first line of the .pic. The following header is typically used: “2, Coast, 7, 0, 0”.  Each parameter (separated by the comma) is defined below.

2

Picture Control Records

Always use number 2

Coast

Name of the picture segment

Leave as Coast

7

Pen color for the Graphics window

0= black

1= red

2=yellow

3=green

4=cyan,

5=blue

6=magenta

7=white

8=gray

0

Line style for the Graphics window

0 = solid

1 = dashed

0

Reserved for future use

NA

Displaying the Picture File in WinFrog

To make your picture file the Working Picture File, perform these steps. 

  1. Select File -> Select Working Files.
  2. Select the Picture radio button, then enter the desired file name and directory location or use the Browse button to find the correct file.
  3. Select Configure -> Graphics from the top pull down menu to enable viewing of the picture.
  4. Edit the contents of the Working Picture File as necessary. Sometimes the files contain an initial point that has coordinates of 0 degrees latitude and 0 degrees longitude. This point should be deleted from the file.
    • Select File -> Edit Working Files -> Picture
    • Select or leave the line that reads COAST
    • Click OK
  5. Select or leave the line that reads Click Select the Background tab
  6. Edit

Geodetics

Overview

Geodetic data are used in geodesy, navigation, surveying by cartographers and satellite navigation systems to translate positions indicated on their products to their real position on Earth. The systems are needed because the Earth is not a perfect sphere. Examples of map data are:

  • WGS 84, 72, 64 and 60 of the World Geodetic System
  • NAD83, the North American Datum (similar to WGS84)
  • NAD27, the older North American Datum, of which NAD83 was a readjustment
  • OSGB36 of the Ordnance Survey of Great Britain
  • ED50 : the European Datum

The difference in co-ordinates between data is commonly referred to as datum shift. The datum shift between two particular datums can vary from one place to another within one country or region, and can be anything from zero to hundreds of meters (or several kilometers for some remote islands).


The Trimble GPS report Latitude and Longitude coordinates in WGS 84 by default. It is recommended to set the WinFrog Geodetics to WGS84 UTM (Universal Transverse Mercator Projection.) WinFrog converts the Latitude and Longitude into Eastings and Northings (meters from an origin.) The UTM parameters in WinFrog have -50000.00m False easting.  The origin is defined by the UTM zone. The UTM zone is a function of longitude.

Procedure: Set Geodetics

To set the geodetics, perform these steps (Figure 8):

  1. Select Configure -> Geodetics.
  2. Select WGS84 UTM in the pull down menu under the General Projection sub-window.
  3. Select the appropriate Zone in the Specific Projection sub-window pull down menu. The zone is based on the current Longitude. This setting must be updated as the vessel moves from one zone to the next when the ship transits.

Note:  It is important when performing a Site Fix to select the correct UTM zone.  Long transits between sites can mean several zone changes.  Be sure when running the Position Averaging Utility the zone for that Site Fix is correct.

Blue Marble Layers

WinFrog v3.10 can display complex coastline data and maps by creating or loading a Blue Marble Layer (BML.) This file type has a .BML file extension. WinFrog has a utility to create the .BML from different file sources (Geotiff maps, vector maps, etc.) See the WinFrog help for more information.

Adding and Editing I/O Devices

Overview

Once you have configured the JOIDES Resolution Vehicle, you are ready to add vehicle devices. The devices covered in this section are the:

  • GPS
  • Gyro
  • NMEA Output Device
  • SeasSpy Magnetometer
  • Depth Data from Bathy 2010

COM Ports

Both WinFrog PCs (WF1 and WF2) are equipped with National Instruments RS232-USB routers that allow them to connect 4 com ports each.  The Bathy2010 depth sounder and SeaSpy Magnetometer are connected to the WinFrog machines through COM ports. The other instruments (GPS and Gyro) and data distribution are wired via TCP/IP into the ships network. The TCP/IP connections are labeled as COM0 devices in WinFrog Vehicle devices. The current com port designations are detailed in Figure 9 and listed below:

COM Port Configurations on WinFrog1 and WinFrog2 using NI RS232-USB router or TCP/IP:

  • COM11 – SEASPY GPS - Out
  • COM12 – SEASPY MAG - In
  • COM13 – BATHY GPS - OUT
  • COM14 – BATHY DEPTH - IN
  • 165.91.72.116 – TRIMBLE - AFT GPS
  • 165.91.72.118 – TRIMBLE - FWD GPS

Adding I/O Devices

To add a device select Configure -> I/O Devices -> Add menu and select each device to be added. This procedure is the same for all devices.

Procedure: Adding a GPS I/O Device

  1. In the Add Device window, expand the GPS device folder (Figure 10, left).
  2. Scroll down and select NMEA GPS (Figure 10, right).
  3. Click OK
  4. Select the TCP/IP radio button after the NMEA GPS Interface dialog box opens (Figure 11).
  5. Type the following device parameters into the TCP/IP Configuration section. A Marine Computer Specialist can provide these details. The device parameters for the Aft and Forward Trimble GPS are:

    Device

    Host Address

    Port Number

    Device Name

    Offset
    FWD/AFT
    Offset
    PORT/STB
    Elev.

    Trimble Aft GPS

    165.91.72.118

    5017

    Aft Trimble GPS – IN

    -73.9m0m

    Trimble Forward GPS

    165.91.72.116

    5017

    Fwd Trimble GPS – IN

    52m-7m16m

                    Note: Either Trimble can act as the Aft or Forward GPS device. The offsets given are for the position of the Trimble when it is connected to the Aft or Forward Antennas. Make sure the host IP address for the Aft or Forward device matches with the Trimble unit set up in that location.

  6. Select the Connection Type to Call.
  7. Click OK



  8. Click Configure -> Vehicles to open the Configure Vehicles window (Figure 12, left) to add the device to the vehicle.
  9. Select Configure Vehicle-Devices (blue rectangle Figure 12, left).
  10. Click Add in the new window (red arrow, Figure 12, right) to open the Select Data Items window.



  11. Make sure the Position and Heading for the GPS (Figure 13) are highlighted in the Select Data Items window.
  12. Click OK.

Setting the GPS Antenna Offset

The origin for the JOIDES Resolution is usually set to the moonpool, therefore, the offset of the GPS antennas from the moonpool must be entered. From the Configure Vehicle-Devices window:

  1. Select the GPS device (Figure 14, left).
  2. Click Edit (red arrow). 
  3. Enter the offset values (green dashed box, Figure 14, right) (aft and stbd values added to the offset boxes should be negative values).


Adding Gyro I/O Device


  1. Select Configure ->I/O Devices -> Add from the top menu.
  2.  In the Add Device window, expand the Gyro device folder.
  3. Scroll down and select NMEA Gyro.
  4. Click OK.
  5. In the window that opens next, select the TCP/IP interface radio button (Figure 11)
  6. Type the TCP/IP Configuration parameters for the Gyro (available from MCS):
    • Host Address: 192.168.190.99
    • Port Number: 10001
    • Device Name: DP Gyro - IN
  7. Click OK.
  8. Click Configure -> Vehicles to open the Configure Vehicles window to add the device to the vehicle.
  9. Select Configure Vehicle-Devices (blue rectangle Figure 12, left).
  10. Click Add in the new window (Figure 12, right) to open the Select Data Items window.


  11. From the Select Data Items window, expand the Gyro device folder to make sure the Heading for the Gyro is highlighted (Figure 16).  Select NMEA Gyro.
  12. Click OK.

Adding NMEA Output Device

This section covers sending navigation information to another system.  National Marine Electronics Association (NMEA) is the output format.  NMEA is output from the GPS and Gyro devices.  The GPS and Gyro are connected to the ship’s network via TCP/IP. This section discusses outputting NMEA navigation data from WinFrog (via RS232 COM Ports or TCP/IP.) to the Bathy2010, SeaSpy Magnetometer, JR Data Server, a data file, the “Unintelligent Design Team” Labview SiteFix program.


  1. In the Add Devices window expand OUTPUT. Select NMEAOUT.
  2. Configure the device according to the table below: 

    Device NameConnect UsingIP AddressCOM/Port numberConnection Options/TypeDevice Parameters
    NMEA to BathyRS232 COM Portsn/aCOM13n/a9600, 8, 1, none
    NMEA to SeaSpyRS232 COM Portsn/aCOM11n/a9600, 8, 1, none
    NMEA to JR Data ServerTCP/IP165.91.72.122128Listen
  3. Click OK.
  4. Select the Configure -> Vehicles top menu to open the Configure Vehicles window.
  5. Select Configure Vehicle-Devices.
  6. Click Add.
  7. Select the output device.
  8. Click OK.
  9. Configure the NMEA output to send the appropriate NMEA strings. 
  10. Right click on NMEAOUT in the I/O Devices screen.
  11. Select Configure Device
  12. Check the message strings to be outputted.  Typically, the Position GGA, Heading HDT, and Time should be output (Figure 17, right). For the "NMEA to JR Data Server" device, also include the Speed.


Depth Data Logger from Bathy2010

This section covers recording the water depth data from the Bathy2010 system into WinFrog. If the information is received directly from another computer, you must use a null modem serial cable.

  1. In the Add Devices window expand SOUNDER.
  2. Select Bathy2000.
  3. Select RS232 COM Ports
  4. In the Device I/O Parameters window:
    • Select a name (e.g., Bathy WD IN)
    • Select COM port = COM14
  5. Select the following device parameter settings:
  6. Baud Rate = 9600
    • Data Bits = 8
    • Stop Bits = 1
    • Parity = none
  7. Click OK.
  8. Add the device to the vehicle.
    • Select the Configure -> Vehicles top menu to open the Configure Vehicles window.
    • Select Configure Vehicle-Devices.
  9. Click Add.
  10. Select the sounder device and click OK.


Device Summary

After all devices are added, the available data items should look like Figure 17 (left panel.)

Configure Vehicle Text (Navigation and Waypoints)

Overview

The vehicle text window displays navigation, recording, and waypoint information.

Procedure: Configure Vehicle Text

To configure the vehicle text, perform these steps:

  1. Select Configure -> Vehicle Text to display the Configure Vehicle Text window (Figure 18), which allows the user to configure the number of rows and columns to be displayed on the screen. For each row, select the line contents from the Available Items list.

An example of what the text configuration will look like in Vehicle Window is shown in Figure 20.  An extra row can always be added, for survey line information, in the event of a seismic survey. To specify an available item to a specific row, select the row number in the Row pull down menu in Figure 19.

Waypoints

Waypoints are sets of coordinates (longitude and latitude) that identify a point in physical space. In GPS navigation, a “route” is usually defined as a series of two or more waypoints. To follow such a route, the GPS user navigates to the nearest waypoint, then to the next one in turn, until the destination is reached. Our drill sites and ports-of-call are waypoints.

Adding Waypoints

To add a waypoint, perform these steps:

  1. Go to the top menu bar, select File -> Edit Working Files -> Waypoints.  The waypoint.WPT screen appears (Figure 21).



  2. Select Add. Enter the name of the waypoint and the position. Optionally you may assign a color, icon and circle radius to help particular waypoints stand out.
  3. Click OK and the new waypoint appears on the graphics screen.

Waypoint Tracking


To set up waypoint tracking, perform these steps:

  1. 1.     Select Configure -> Vehicles from the menu bar.
  2. 2.     Click Setup Waypoint Tracking.
  3. Select the next waypoint the JR will track from the waypoints file in the Setup Waypoint Tracking window (Figure 23). When a waypoint is selected to track, the name and range will appear in the Vehicle Window.

When a waypoint is selected to track, the name and range will appear in the Vehicle Window.


WinFrog Data Logging

Overview

Logging data in WinFrog is performed by what are called Events. The user must define the data to be collected and at what interval of time. Data are written to two files:

  • .dat
  • .raw

The destination folders for these files are set up in the working directories window and should be set up at the beginning of each Expedition.

Data is collected at all times (for transits and while on-site) throughout an expedition. Start the:

  • Transit event just as you are leaving port or your site
  • Site event just as you come on to site.

Procedure: Data Event Set-up

To start logging an event for a transit or at a hole, perform these steps:

  1. Select Configure -> Data Events -> Setup from the top menu to open the Event Configuration.
  2. Select the Eventing tab, if it opens in different tab in the Event Configuration window.
  3. Select the Time button in the Trigger subwindow.
  4. Select the Manual Start button in the Event Start subwindow.
  5. Select the Data Logging [.DAT] button in the Record Type subwindow.
  6. Set the interval in which data will be recorded (blue dashed box in Figure 24).
  7. Select the Raw Data tab.
  8. Select the At Events button in the Logging Control subwindow so raw (*.raw) data will be collected at the same interval as the eventing (*.dat) data.
  9. Click OK and the Event Secondary Configuration window opens (Figure 25). This is an option to setup another event log file with a new filename.

  10. If you want to setup your next event, type the file name in the File Name box.
    • Expeditions use the expedition number, underscore, followed by the line or hole number (e.g., 317_U1338A).
    • Transits use an “L” to indicate line, a number for the line number, and “T” for transit (e.g., L1T).
    • A survey line will use an “S” (e.g., L4S).
    • Holes will use the hole number which consists of the site number and the hole letter designation (e.g., U1338A).
  11. Click OK.

In the Vehicle Window, notice how the fields related to eventing are enabled and ready to be started (Figure 26).

Start Event Logging

On the Main Screen, click the green Event Start (FX) icon (Figure 27) to start data logging. Now data are being logged.

Stop Event Logging

To stop event logging, perform these steps:

  1. Click the red STOP icon (Figure 28) to suspend event logging and open the Event Secondary Configuration window (Figure 25). The user can:
    • Cancel at this point
    • Change the name to the next file to be recorded
    • Keep the same name and continue logging to it by appending more data (the user will be prompted with the option to append or overwrite).

      The naming scheme has changed in the new Winfrog version.
  2. Click OK or Cancel, depending on the action to be done.
  3. Click the green (FX) icon on the main menu (Figure 27) to continue logging.


WinFrog Site Fix

Overview

The Operations Superintendent will need a position (latitude, longitude) for each hole. The position will be determined by averaging the navigation data fixes recorded while the drill string is in the hole.  The data are from the IODP Forward and Aft GPS.  Although a separate Site Fixer program is available to IODP Techs, WinFrog also has a Site Averaging Utility.  

Data Event Logging

When coming on site, stop your transit data event and start a new data event for the site’s first hole as described in the Data Event set-up procedure. Remember to create a new event data file (ex. U1337A.dat) for each hole.

Position Averaging

WinFrog utilizes a utility called Position Averaging to average a position for a vehicle.  Fugro Pelagos modified their position averaging utility for IODP in order for us to utilize recorded data files to determine hole positions.

Procedure: Select FILEs

To average a position for a vehicle, perform these steps:

  1. Select Utilities -> Position Averaging from the top menu to open the Position Averaging window.
  2. Select Reprocess Position Averaging Data from Disk.
  3. Under Position Averaging (Figure 29), select Load (red arrow left figure). The Select Position Averaging Data window will appear (right figure).
  4. Click on Select Files (blue arrow right figure) and browse to the correct data file (dashed blue box).

Determine Position of a Hole

Once the file has been selected, the time window of data must be selected. Determine the time window in which the drill string was in the Hole (GMT) by performing the steps in the Procedure: Determine Hole Position. To be safe, shave off 15 minutes or so from the beginning and end of the window. This will throw out most of the potential outliers as the ship settles into position. The key is to only use data collected when the pipe is actually in the hole.

During Expedition 321, the Operations Manager suggested using a time range of core 3’s time on deck (TOD) to the TOD of the last core of the hole.

Procedure: Determine Hole Position

To determine Position, perform these steps:

  1. In the Select Data to Load section of the Select Position Averaging Data window (Figure 30), enter the range of time (red oval) the pipe was in the hole. 
  2. Click the Scan Files button (red arrow), which checks the file to see if the time window selected is in the file.
  3. Click OK.
  4. The Position Average for J. Resolution window (Figure 31) will display the Mean Position and Standard Deviations. An acceptable position has standard deviations less than two meters. You can also get the Northing and Easting values by selecting the Grid button to the right of the Mean Position.
  5. If the position is acceptable, enter a comment in the comments field (red box in Figure 31) (ex: site/hole information).
  6. Provide the information to the Operations Manager by taking a screen capture of the active window (<Ctrl> - <Alt> - <Print Scrn>) and then pasting the capture into Microsoft Word or following the PC Screen Shot Capture Instructions document located in Cumulus to save the screen capture as a tif file.
  7. Click on Save (green box). Save this file to the Expedition’s Position folder. The file extension is .aep. Use a file name with the Expedition and hole (i.e. Exp321_U1337A.aep). This file can be loaded into the Position Average Utility to view again.
  8. You can also provide a cover sheet for the screen capture, making the important information easier for them to parse (see Position Averaging Report).

Position Averaging Report

From Figure 31, select the Save option and navigate the file to be placed in the Expedition’s position folder.  An .rtf file is created, where the screen capture can be pasted and a PDF generated.   Print the document and give to the OPS Manager (and/or Staff Scientist if you wish). Save a copy to the Position folder.

If the position is not acceptable go back to Determine Position of a Hole (Figure 29) and try the following:

•Change the window of time (this may take a few tries).

•If you can identify some bad data, go to the Observed Data section, select those points not to be used, and click Re-Calculate.



Archive Versions

WinFrogNavigationUserGuide.pdf - Feb. 24, 2020

  • No labels